CMS DataLife Engine - Система управления сайтами

DeeMon

Переход с http на https

Переход с http на https  

84 members have voted

  1. 1. Планируете ли переход с http на https?

    • Да
      41
    • Нет
      13
    • Уже на https
      30


Recommended Posts

1 час назад, rusrob сказал:

Получил сертификат на сайт на дле, в настройках сайта заменил на https, через поиск и замена автоматом поменял все ссылки на https, но в итоге на главной сертификат полностью защищен, а на внутренних - неполностью (желтый). Пишет, что картинки не защищены. Пробовал в .htacess вписать предлагаемые выше коды, но не помогло. Как это исправить? Заранее спасибо за помощь.

в этой теме всего 3 страницы с ответами, прочитать минут 10, максимум... https://forum.dle-news.ru/topic/69025-переход-с-http-на-https/?do=findComment&comment=344142

 

Share this post


Link to post
Share on other sites
1 час назад, rusrob сказал:

Получил сертификат на сайт на дле, в настройках сайта заменил на https, через поиск и замена автоматом поменял все ссылки на https, но в итоге на главной сертификат полностью защищен, а на внутренних - неполностью (желтый). Пишет, что картинки не защищены. Пробовал в .htacess вписать предлагаемые выше коды, но не помогло. Как это исправить? Заранее спасибо за помощь.

Что за глупость через .htaccess такое решать?

Просто замените в БД все http картинок на https

Share this post


Link to post
Share on other sites
В 02.09.2016 в 15:15, webair сказал:

Host: https://site.ru
Sitemap: https://site.ru/sitemap.xml

 

Ну а если у меня сайт один и 10 зеркал. То мне как это написать?

Share this post


Link to post
Share on other sites
21 минуту назад, IMPERATOR сказал:

Ну а если у меня сайт один и 10 зеркал. То мне как это написать?

В 10 зеркалах указываете host главный сайт, так же как и на основном сайте

Share this post


Link to post
Share on other sites

Добрый день, помогите решить проблему, при переходе на https в старых новостях не открывается lech ссылки, если нажать редактировать новость и сохранить, то начинает работать, а теперь вопрос, как это сделать массово для всех новостей?

Share this post


Link to post
Share on other sites
4 часа назад, gfunbary сказал:

Добрый день, помогите решить проблему, при переходе на https в старых новостях не открывается lech ссылки, если нажать редактировать новость и сохранить, то начинает работать, а теперь вопрос, как это сделать массово для всех новостей?

В админ панели сделать «перестроение публикаций»

Share this post


Link to post
Share on other sites

Здравствуйте!

 

Помогите решить проблему - перешел с http на https. DLE старенький, 9.6, сервер - nginx

Все вроде работает кроме конструкции в новостях типа [media=560x315,https://www.youtube.com/watch?v=l92J1UvHf6M], если просто по http - нормально показывает видео с Ютуба, а по https - пустое место. Куда копать?

 

Заранее благодарю

Edited by AkaUfo

Share this post


Link to post
Share on other sites
2 часа назад, AkaUfo сказал:

Здравствуйте!

 

Помогите решить проблему - перешел с http на https. DLE старенький, 9.6, сервер - nginx

Все вроде работает кроме конструкции в новостях типа [media=560x315,https://www.youtube.com/watch?v=l92J1UvHf6M], если просто по http - нормально показывает видео с Ютуба, а по https - пустое место. Куда копать?

 

Заранее благодарю

Разобрался сам.

Если кому интересно - в файле /classes/parse.class.php надо найти строчку

<iframe title="YouTube video player" width="'.$width.'" height="'.$height.'" src="http://www.youtube.com/embed/'

и поставить https здесь - 

https://www.youtube.com/embed/

после чего выполнить "Перестроение публикаций" в админке

  • Thanks 1

Share this post


Link to post
Share on other sites

Спасибо всем форумчанам. Информация очень помогла. Однако, есть вопрос.

DLE 10.1 

Пользователи оставляют в комментариях ссылки и вставляют картинки с других ресурсов с http. Браузеры предупреждают, что страница небезопасна. Как с этим бороться?

 

Автозамена с http на https не поможет, т.к. в коде идёт замена с тэгами и ссылка не генерируется.

Насколько я понимаю, нужны ссылки вида  //site.ru. Как это сделать, где что исправить?

 

Заранее благодарю за помощь!

Share this post


Link to post
Share on other sites
5 часов назад, denka сказал:

Пользователи оставляют в комментариях ссылки и вставляют картинки с других ресурсов с http. Браузеры предупреждают, что страница небезопасна. Как с этим бороться?

Никак, потому что все загружать именно по https это обязательное требование SSL протокола. А сторонние сайты могут банально не иметь вообще поддержки https протокола. В данном случае только запрет на публикацию картинок обычным посетителям или только разрешать загрузку картинок на ваш сайт.

Share this post


Link to post
Share on other sites

целый ряд функций отваливается с этим SSL: проблема с картинками и ссылками в комментариях. сильно ограничивает общение. очень жаль.:(

Share this post


Link to post
Share on other sites
38 минут назад, denka сказал:

елый ряд функций отваливается с этим SSL: проблема с картинками и ссылками в комментариях.

ссылки то здесь причем? Куда ссылаются ссылки на http или https абсолютно не важно. Важно только то что загружается на страницу вашего сайта, а не что куда потом ведет.

Share this post


Link to post
Share on other sites

Ясно.

 

Можно ли что-то придумать на 10.1, чтобы не было алярмы браузеров от картинок в комментариях по http?

Share this post


Link to post
Share on other sites
20 часов назад, denka сказал:

Можно ли что-то придумать на 10.1, чтобы не было алярмы браузеров от картинок в комментариях по http?

Нет, т.к. это уже не от DLE зависит, а требование SSL протокола.

Share this post


Link to post
Share on other sites

Всем привет.

Установил сертификат и вот какая проблема:

 

Под шаблонами Red и Default - проблем нет отображается, что сайт полностью защищен, а в шаблоне Green - пишет что не полностью защищен (ссылается на какие-то незащищенные картинки). Передрал весь шаблон и ничего...

Может не там копаю? Подскажите

 

Версия DLE 12

 

Спасибо

Share this post


Link to post
Share on other sites
14 часа назад, parfa08 сказал:

Всем привет.

Установил сертификат и вот какая проблема:

 

Под шаблонами Red и Default - проблем нет отображается, что сайт полностью защищен, а в шаблоне Green - пишет что не полностью защищен (ссылается на какие-то незащищенные картинки). Передрал весь шаблон и ничего...

Может не там копаю? Подскажите

 

Версия DLE 12

 

Спасибо

Откройте консоль браузера там будет написано что именно у вас загружается не https

  • Thanks 1

Share this post


Link to post
Share on other sites
2 часа назад, mlide сказал:

Скажите, почему я поставил в настройках https://mixmovie.ru/ , а карта сайта у меня формируется с http адресами https://mixmovie.ru/sitemap.xml

все правильно там формируется, с https

  • Like 1

Share this post


Link to post
Share on other sites
34 минуты назад, alex32 сказал:

все правильно там формируется, с https

Да, действительно, но до этого было http, возможно кэш

Share this post


Link to post
Share on other sites

Все сделал как нужно,но нет зеленого значка,скрипт стандарт ,все ссылки использую  https, но нет толку.Может кто что подскажет?

Share this post


Link to post
Share on other sites
1 час назад, melkij сказал:

Все сделал как нужно,но нет зеленого значка,скрипт стандарт ,все ссылки использую  https, но нет толку.Может кто что подскажет?

как нужно, это как?

SSL сертификат установлен, валидный?

Share this post


Link to post
Share on other sites
В 16.02.2018 в 23:49, prikindel сказал:

как нужно, это как?

SSL сертификат установлен, валидный?

Все сделал как надо,на хосте сертификат + переход на  https,в админке включил переход,и ссылку указал  https,при загрузке сайта 2 секунды светит что защищено,но когда сайт полностью загружается то значек пропадает.В нотепад закинул стандартный шаблон (дефаулт) и заменил сылки с  http на  https ,но толку нет.При загрузке сайта есть зеленый а когда загрузился сайт то значек пропадает. пример вот f-ferma.ru

Share this post


Link to post
Share on other sites
24 минуты назад, melkij сказал:

Все сделал как надо,на хосте сертификат + переход на  https,в админке включил переход,и ссылку указал  https,при загрузке сайта 2 секунды светит что защищено,но когда сайт полностью загружается то значек пропадает.В нотепад закинул стандартный шаблон (дефаулт) и заменил сылки с  http на  https ,но толку нет.При загрузке сайта есть зеленый а когда загрузился сайт то значек пропадает. пример вот f-ferma.ru

Потому что на странице огромное количество контента с  http. Такие как картинки, еще какие то ссылки на всяких чатах дебильных. Для начала в разделе админки  "Поиск и Замена"  заменить все http://f-ferma.ru/ на https://f-ferma.ru/. Потом открыть исходный код и смотреть, какие ссылки еще остались с http. Ну и шаблон проверить.

  • Thanks 1

Share this post


Link to post
Share on other sites
10 часов назад, alex32 сказал:

Потому что на странице огромное количество контента с  http. Такие как картинки, еще какие то ссылки на всяких чатах дебильных. Для начала в разделе админки  "Поиск и Замена"  заменить все http://f-ferma.ru/ на https://f-ferma.ru/. Потом открыть исходный код и смотреть, какие ссылки еще остались с http. Ну и шаблон проверить.

Вроде сделал замену через админку,а вот открыв исходный код,то заметил что картинку из профиля берет с  http,но как и где искать  не подскажите?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now