Jump to content
Sign in to follow this  
Altyn

12 версия и meta name="description"

Recommended Posts

сайт altynclub.ru

 

Версия DataLife Engine:

12.0
Тип лицензии скрипта: Лицензия активирована
Операционная система: Linux 3.4.6
Версия PHP: 5.3.29
Версия MySQL: 5.1.36 MySQLi
Информация о GD: GD Version: bundled (2.1.0 compatible), FreeType Support: Enabled, FreeType Linkage: with freetype, T1Lib Support: Disabled, GIF Read Support: Enabled, GIF Create Support: Enabled, JPEG Support: Enabled, PNG Support: Enabled, WBMP Support: Enabled, XPM Support: Disabled, XBM Support: Enabled, JIS-mapped Japanese Font Support: Disabled,
Module mod_rewrite Включен
Безопасный режим: Выключен
Выделено оперативной памяти: 256M
Отключенные функции: Неопределено
Максимальный размер загружаемого файла: 2 Gb
Размер свободного места на диске: 802,4 Gb

 

Возможно, что после обновления с 11.3 при размещении статей, созданных в 12.0 в фейсбук перестало подтягиваться само тело статьи в пост фейсбуке. Со старыми статьями все нормально. Кеш обновлял, статьи перестраивал. Ткните меня носом, где я накосячил или это не мой баг?

 

Edited by Altyn

Share this post


Link to post
Share on other sites
52 минуты назад, Altyn сказал:

Возможно, что после обновления с 11.3 при размещении статей, созданных в 12.0

Нет, с обновлением DLE это не связано, т.к. фейсбук берет ваш контент напрямую из вашего сайта, на основе его верстки, и собственно самого контента. А это DLE не менялось и зависит только от того как вы публикуете свои новости и что там пишите.

Share this post


Link to post
Share on other sites
46 минут назад, celsoft сказал:

Нет, с обновлением DLE это не связано

Спасибо за ответ, но тогда мне не понятно, почему старые статьи нормально фейсбуком обрабатываются на тех же настройках?

 

Это может быть из-за смены редактор? Старые статьи были написаны Froalaeditor, но от него пришлось отказаться, т.к. теперь вставить картинку в статью у меня не получается. :-( Почему-то на выходе сохраняется такой код:

<img src="" alt="" class="fr-dii fr-fil">

 

Share this post


Link to post
Share on other sites
1 час назад, Altyn сказал:

Старые статьи были написаны Froalaeditor

 

1 час назад, Altyn сказал:

теперь вставить картинку в статью у меня не получается. :-( Почему-то на выходе сохраняется такой код <img src="" alt="" class="fr-dii fr-fil">

Ничего не понял, это два взаимоисключающие сообщения. Вы пишите что не пользуетесь FroalaEditor и тут же приводите код именно от FroalaEditor, только он генерирует такой код.

Share this post


Link to post
Share on other sites
7 минут назад, celsoft сказал:

код именно от FroalaEditor, только он генерирует такой код.

 

Я и отказался он FroalaEditor, т.к. он вместо кода с картинкой генерит то, что я написал. Так понятнее стало или по редактору отдельную тему создать?

Share this post


Link to post
Share on other sites
2 минуты назад, Altyn сказал:

Я и отказался он FroalaEditor, т.к. он вместо кода с картинкой генерит то, что я написал.

То что вы привели, это и есть код картинки. И никаких проблем со вставкой картинок он точно не имеет, как и любой другой редактор.

3 минуты назад, Altyn сказал:

Так понятнее стало или по редактору отдельную тему создать?

Мне понятно что вы отказались от этого редактора. Но непонятно, чем вы сейчас пользуетесь после отказа от него, по вашему сообщению я так понял что опять FroalaEditor. Если нет то каким? А вообще редакторы генерирует почти одинаковый код, лишь с небольшими различиями, повлиять они вряд ли как то могут на  фейсбук. Сказать точно почему фейсбук у вас не берет контент, вам может только служба поддержки фейсбука т.к. только им известно по каким алгоритмам и критериям работает их система.

Share this post


Link to post
Share on other sites
4 минуты назад, celsoft сказал:

То что вы привели, это и есть код картинки.

Да, но только в этом коде нет ссылки на саму картинку. Должно же быть вот так:

<img src="http://картинка.jpg" alt="" class="fr-dii fr-fil">

Сейчас вместо FroalaEditor использую TinyMCE, мне казалось это очевидным решением. Странно, что простые логические цепочки приходится разжевывать главному администратору, :-( 

Share this post


Link to post
Share on other sites
22 часа назад, Altyn сказал:

Да, но только в этом коде нет ссылки на саму картинку.

 

22 часа назад, Altyn сказал:

Странно, что простые логические цепочки приходится разжевывать главному администратору, :-(

Если бы вы были главным администратором, то знали бы сколько людей удаляют часть кода не потому что это так скрипт оставил, а потому что они не хотят "светить" часть данных, поэтому всегда я и пишу, чтобы расписывали что именно не так. Чтобы описывали что добавляют, и что конкретно в результате остается, потому как причиной проблемы может быть все что угодно. 

 

Например вы написали: "вставить картинку в статью у меня не получается". Все больше ничего не написали. Только вот правило "Краткость сестра таланта", не работает при решении проблем. И возникает тонна различных дополнительных вопросов, потому как существует такая же тонна причин по которой может возникнуть данная проблема. Например в вашем конкретном случае может быть причиной ваш написанный там адрес к картинке, может быть проблема с именем домена, с именем пути, именем файла и т.д.  А вы только после пятого дополнительного вопроса написали http://картинка.jpg заменяется на пустоту, и то написали опять сокращенное какое имя с протоколом и без домена, и это не адрес картинки, и логично что подобное удалил редактор. И я уверен что это не то что вы написали в редакторе, а просто опять сократили для собственного удобства. Поэтому всегда пишите все полностью, без ваших личных сокращений и изменений. Например: вставляю то то и то то (полный адрес именно того что вставляете) без изменений и сокращений и на выходе получаю то то и то то (без изменений и сокращений). И на основе именно ваших конкретных данных, будет проведена проверка  в дистрибутиве, и есть ли такая проблема на чистом дистрибутиве. Если есть, то баг пойдет в работу для исправления. Если нет на чистом дистрибутиве, поддержка будет проверять именно на вашем сервере.

 

А вы что написали? Просто у меня не вставляются картинки и все. А у десятков тысяч людей они вставляются в данном редакторе.

 

P.S. Странно, что такие простые логические вещи о том как нужно описывать проблему, приходится писать веб мастеру и администратору сайта, который создает и делает свой сайт, ведь любой веб мастер и администратор должен понимать эти простые вещи, и знать что любая мелочь важна, т.к. причины проблем бывают разные и возникают из за разных условий.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...