Перейти к публикации

После обновления до версии 15.3 не работает админка и сайт на PHP 8.1


Рекомендованные сообщения

Ситуация такая. Обновил с версии 15.1 до версии 15.3. Вылезло что устарел PHP и надо поставить новый, не ниже 8.1

Хостинг SWEB, там кликаеш на настройки и выбираешь. Стояла 2.2 апаче и 7.3 пхп. Поставил 2.4 апаче и 8.1 пхп.

В результате и сайт и админка грузятся без картинок и без css. В чем может быть проблема? Пока вернулся на прежнюю версию апаче и пхп.

Понятно что проблема не в скрипте, что сказать хостинг провайдеру?

Изменено пользователем Dnny
Ссылка на сообщение
Поделиться на других сайтах

Проблема в хостинге, но не в PHP а именно в Апаче, они напрочь отказываются ставить для Apache 2.4 модуль mod_access_compat, который нужен для работы директив. Они требуют при этом перехода на их VDS тарифы. Поэтому если вы не можете перейти, то придется переписывать правила. Прочитайте все комментарии к релизу https://dle-news.ru/release/1869-datalife-engine-v153-final-release.html#comment там как раз про ваш хостинг пишут:

Цитата

У вас же на хостинге в документации написано что нужно делать (что чему соответствует) https://help.sweb.ru/entry/1035/

ОТКЛОНИТЬ ВСЕ ЗАПРОСЫ
Apache 2.2

Order deny,allow
Deny from all

Apache 2.4

Require all denied

РАЗРЕШИТЬ ВСЕ ЗАПРОСЫ
Apache 2.2

Order allow,deny
Allow from all

Apache 2.4

Require all granted

Это нужно делать по всем файлам .htaccess где встречается 

Цитата

Order deny,allow
Deny from all

и

Цитата

Order allow,deny
Allow from all

Ну или переходить на их VDS тарифы где они соизволят включить нужные модули Апача

Ссылка на сообщение
Поделиться на других сайтах

Спасибо, пошел дрючить их тех поддержку для начала.

Ссылка на сообщение
Поделиться на других сайтах
3 минуты назад, Dnny сказал:

Спасибо, пошел дрючить их тех поддержку для начала.

Другие клиенты уже пробовали )) и у них не получилось )), отправляют на тариф дороже всегда, но чем больше будет просить быстрее сделают. Они ссылаются что этот модуль может якобы помешать настроенной работе других сайтов, но это не правда потому что модуль mod_access_compat только добавляет поддержку работы Order deny,allow и больше ничего, соответственно он больше ничему не мешает и не может помешать. Так что я думаю это умышленно сделано как скрытая отправка на более дорогие тарифы где все работает волшебным образом ))

Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, celsoft сказал:

Другие клиенты уже пробовали )) и у них не получилось )), отправляют на тариф дороже всегда, но чем больше будет просить быстрее сделают. Они ссылаются что этот модуль может якобы помешать настроенной работе других сайтов, но это не правда потому что модуль mod_access_compat только добавляет поддержку работы Order deny,allow и больше ничего, соответственно он больше ничему не мешает и не может помешать. Так что я думаю это умышленно сделано как скрытая отправка на более дорогие тарифы где все работает волшебным образом ))

Опыт общения с ними с нужен :) я у них с 2005 года клиент. Возможно студентов набрали в ТП, или старики ленивые стали.

Ссылка на сообщение
Поделиться на других сайтах

Отпишитесь потом о результате, даже интересно получиться у вас или нет )) искренне желаю вам удачи.

Ссылка на сообщение
Поделиться на других сайтах
21 минуту назад, celsoft сказал:

Отпишитесь потом о результате, даже интересно получиться у вас или нет )) искренне желаю вам удачи.

Раньше можно было позвонить или написать и в течении часа уже нужные модули стояли и работали. Видимо другая политика, новые люди. Меня не послали оплачивать VDSчто уже хорошо. Ответ был более лаконичен:
 

Цитата

На услуге виртуального хостинга в Apache 2.4 не установлен модуль mod_access_compat, произвести его установку мы не можем в силу технических ограничений услуги. Для использования PHP 7.4 и новее необходимо заменить директивы ограничения доступа на более новые. Общие рекомендации приведены на нашем сайте: https://help.sweb.ru/entry/1035/

В результате пришлось все делать руками. Ну по крайней мере все заработало. :)

Ссылка на сообщение
Поделиться на других сайтах

Я с такой проблемой не сталкивался, но походу, "раз такая пьянка", это нужно указать в минимальных требованиях на сайте DLE, для Apache про "mod_access_compat", мысли вслух и не более того.

Изменено пользователем Captain
Ссылка на сообщение
Поделиться на других сайтах

После моего вопроса:

Цитата

Не связано ли техническое ограничение что этот модуль стоит только на VDS? И пользователям хотящим работать на пхп версии 8.1 настоятельно рекомендуется переходить на более дорогостоящие тарифы со своими хотелками?

мне ответили так:
 

Цитата

Мы запросили у профильных специалистов информацию о возможности установки модуля mod_access_compat на текущий момент, по факту рассмотрения вопроса мы направим уведомление в рамках этой заявки. Благодарим за ожидание.

в общем еще надо подождать.

Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, Dnny сказал:

В результате пришлось все делать руками.

Целенаправленный мазохизм!))

Что мешает перейти на нормальный хостинг? Например: ipipe.ru.

Что людьми движет - цепляться за говнохостинг, да еще с завышенной стоимостью.

3 часа назад, Dnny сказал:

в общем еще надо подождать.

Беги!

Ссылка на сообщение
Поделиться на других сайтах
22 часа назад, kamensk сказал:

Целенаправленный мазохизм!))

Что мешает перейти на нормальный хостинг? Например: ipipe.ru.

Что людьми движет - цепляться за говнохостинг, да еще с завышенной стоимостью.

Беги!

Я выбрал хостинг в своем городе, я с ним с 2005 года и являюсь их партнером. Получаю очень хорошие бонусы за своих клиентов и мне нравится их техподдержка. А по другим хостингам могу сказать что мне не нравится и панель управления, ни тех поддержка, ни падения серверов. Для меня мой хостинг вполне дешевый, Вы его пробовали чтобы обсуждать его? Или для вас главное побольше халявы? Хотите подешевле, бегите. Обсуждайте свой хостинг в другом месте.

Ссылка на сообщение
Поделиться на других сайтах
2 часа назад, Dnny сказал:

Для меня мой хостинг вполне дешевый, Вы его пробовали чтобы обсуждать его?

Я уже по содержанию вашей темы сделал верный вывод - что представляет  ваг хостинг.))

Ссылка на сообщение
Поделиться на других сайтах

Важная информация по хостингу SWEB!

Модуль "mod_access_compat" был установлен на сервер, старые директивы ограничения доступа работают на всех версиях PHP.

Так что теперь не надо переходить на дорогие тарифы. Просто надо нормально с ТП пообщаться.

 

Ссылка на сообщение
Поделиться на других сайтах
4 часа назад, Dnny сказал:

не надо переходить на дорогие тарифы. Просто надо нормально с ТП пообщаться

На нормальных хостингах - сервера настраиваются так -стараются, чтобы было меньше повода для обращения в ТП.

Изменено пользователем kamensk
Ссылка на сообщение
Поделиться на других сайтах

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить в тему...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

×
×
  • Создать...