Перейти к публикации

ovpmusic2

новички
  • Публикации

    22
  • Зарегистрирован

  • Посещение

Репутация

0 Обычный

О ovpmusic2

  • Звание
    Новичок
  • День рождения 16.10.1965

Информация

  • Пол
    Мужчина
  • Город
    Алушта
  • Интересы
    Музыка, программирование
  1. Я и не пытался вами манипулировать. Это ваше собственное видение моих слов... Я просто задал вопрос на который так и не получил ответ. Наверно и не получу... Вы сами то поняли что написали? А сайт тогда вообще зачем, он вообще-то в браузере открывается... Или это опять только мое видение? Я уже несколько раз написал как должна работать эта возможность. Теперь вы внимательно прочитайте всё что я писал выше... Даже интересно во что выльется калькуляция реализации того что я хочу для меня? А вы ведь потом это для всех в скрипт внедрите... Так что я подожду, пока
  2. А вы всё пишите также как и 20 лет назад? Технологии вообще-то меняются и время идет вперед. И значит я буду первым кто задал вам такой вопрос... Вам лень или вы не знаете как сделать так, чтобы авторизация не сохранялась если пользователь выберет такую опцию при входе на сайт или администратор пропишет это жестко в шаблоне login.tpl независимо от настроек браузера пользователя? Если не знаете как - признайте это. Если знаете как - реализуйте или подскажите что изменить в файлах скрипта чтобы это реализовать... Если вы хотите пооскорблять других, то вам на другой форум.
  3. Это не мое собственное видение. Это баг в DLE или недоделанная до конца возможность. Какой смысл в том как это работает сейчас? Вообще никакой... Запишу видео и пришлю как это должно работать. Не на сайте банка и не на сайте какой-то супер секретности или безопасности. Я вам предлагаю изменить ваш подход к моменту сохранения или несохранения авторизации. Пользователи потом спасибо скажут. Но если вам лень, или вы не знаете как это реализовать чтобы это работало независимо от настроек браузера, тогда... А по поводу админа, который всё видит, то для этого и существует
  4. Начните пользоваться этим и сами увидите баг в DLE... Наконец-то. Разобрались в причине!!! Ура!!! Вот в этом то все и дело и функция в DLE работает некорректно если у пользователя в настройках браузера установлено "Восстанавливать последние открытые вкладки при запуске браузера". Почему я говорю, что в DLE эта функция работает некорректно в этом случае, потому что я пользуюсь другими сайтами у которых эта функция работает корректно несмотря на настройки в браузере( хороший пример: myfxbook.com или сайты банков) и если я не захочу сохранять авторизацию она не сохранится и после п
  5. Вы видели на видео как это работает?... После долгих экспериментов, в разных операционных системах, а также в разных браузерах, пришел к выводу, что если пользователь захочет не сохранять авторизацию, то сначала ему придется организовать кое-что в своем браузере, а именно: 1. Не сохранять введенные пароли (что очень неудобно). 2. Отключить восстановление открытых вкладок, которые были открыты перед его закрытием (также неудобно). 3. Не сохранять куки в браузере и т.д. В общем сплошные неудобства... В связи с этим вопрос: на какой срок сохраняются куки от DLE в бра
  6. В общем, не сбрасывается авторизация так, как это должно работать. В Linux это так же не работает. Чтобы это работало, нужно, скорее всего, свой браузер настроить так, чтобы в нем ничего не сохранялось, но тогда информация с других сайтов, которую желательно сохранить, тоже не будет сохраняться. В общем, на пару дней оставлю доступы на сайт открытыми для экспериментов и проверок, может кто найдет решение. Единственно что будет закрыто - это управление плагинами... Со всем остальным, желающие можете экспериментировать... Всё равно, думаю, что решения у этого бага нет, пока
  7. Я это прекрасно понимаю, что DLE всё равно с какого устройства я захожу на сайт. Скрипт работает на сервере - это я тоже понимаю. Выше я писал и показал на втором видео, что сейчас при переходе по внутренним ссылкам сайта всё работает правильно, авторизация не сбрасывается (причем это заработало само собой, за несколько минут до этого не работало и это видно на первом видео). Но авторизация и не сбрасывается при закрытии, и повторном открытии браузера. см. видео здесь: https://disk.yandex.ru/i/oNrm0KxSQ7NFaQ Изменений в настройках сервера и в скрипте никаких не производилос
  8. Я извиняюсь, но при чем здесь это если на Mac Book и на iPhone всё работает как надо без этих правок, и не важно под какой учетной записью я вошел на сайт, пользователем или администратором. Я здесь писал об этом: Хостинг на Beget, никаких особых или дополнительных настроек сервера я не делал. Если это некорректные настройки сервера, почему тогда на на устройствах от Apple всё работает правильно. Я же уже писал об этом. Проблема почему-то только в операционной системе Windows Linux еще не установился чтобы проверить там. Установится - проверю и отпишусь о результ
  9. Провел тесты на iPhone - все работает правильно. Провел тесты на Mac Book, в Safari и в YandexBrowser - тоже всё работает правильно. Есть идеи почему в Windows глючит? Повторюсь, чтобы не было ненужных советов, что мой комп ни при чем, т.к. тесты делал еще и на VPS, где система Windows и браузеры "девственные". Везде перед тестами производилась очистка cookie и всей истории за всё время. Да, на устройствах от Apple я такой чистки не делал и всё работает как надо... Буду благодарен любым советам! P.S. Попробую установить Linux в виртуальную машину и проверить там.
  10. Вот еще видео с тестами на VPS: https://disk.yandex.ru/i/oNrm0KxSQ7NFaQ Причину такого поведения скрипта я пока понять не могу...
  11. Странно. После публикации моего сообщения прошло 40 минут. Пока занимался другими делами, всё как-то само собой решилось, но опять не туда... Зарегистрировался как тестовый пользователь. Проверил авторизацию. При переходе по внутренним ссылкам авторизация не слетает. Но зато теперь опять при закрытии/открытии браузера (любого) авторизация не уходит. Что происходит? Кто-то может дать ответ? Пойду проверю тоже самое с виртуального сервера (VPS) чтобы исключить проблемы в моем компе. Позже отпишусь... Проверил на VPS - проблема остается. Т.е. мой компьютер и мои
  12. Куки очищены во всех браузерах - не помогает. Теперь провожу эксперимент: Установил на доп домен с чистого листа. Настройки скрипта по умолчанию. Добавил в login.tpl стандартного шаблона конструкцию: <input type="hidden" name="login_not_save" value="1"> Авторизовался. Закрыл браузер. Опять открыл. Авторизации нет. Отлично! Работает! НО! Авторизуюсь снова и открываю полную новость... Авторизации нет! Т.е. если я авторизован и перехожу по внутренним ссылкам на сайте авторизация уходит... см. видео здесь: https://disk.yandex.ru/i/fVSllQd4P
  13. Модификаций нет. Плагины свои стоят (отключал все - не помогло). В шаблоне login.tpl код стоит перед закрывающим тегом </form> Вот эта часть кода: <form> ... <div class="submit"> <button type="submit" class="btn btn-primary btn-block">Войти на сайт</button> </div> <p class="mb-2">Забыли пароль? <a href="{lostpassword-link}" >Нажмите для восстановления</a></p> <p class="mb-0">Еше нет аккаунта? <a href="{registration-link}" class="openregisterbox">Нажмите для регистрации</a></p> <input name=
  14. Здравствуйте, всем! Столкнулся с проблемой, что не сбрасывается авторизация при закрытии браузера. Т.е. в форме авторизации прописан следующий код: <input type="hidden" name="login_not_save" value="1"> Но после закрытия браузера и повторного открытия авторизация не сбрасывается. Версия скрипта последняя, 17.1 Браузер не причем, т.к. это наблюдается во всех браузерах и на разных компьютерах. При чем в этом же браузере и на этом же компьютере на сайте dle-news.ru всё работает как надо и после закрытия и повторного открытия браузера пользователь не авторизован.
  15. Открывал. Ошибок не было. Может кому пригодится, проблема решена так: <?php ... // Если ошибка есть, то выводим её if ( ! empty( $error ) ) { $err = array_shift( $error ); echo <<<HTML <script> window.addEventListener('load', ()=> { const acc = '{$err}'; if (acc) DLEPush.warning('{$err}', 'ОШИБКА'); }); </script> HTML; } ... ?> Только не могу понять почему так не выводит: <?php ... // Если ошибка есть, то выводим её if ( ! empty( $error ) ) { $err = array_shift( $error ); echo <<<HTML <script> D
×
×
  • Создать...