CMS DataLife Engine - Система управления сайтами

stas84

Загрузка файла завершилась ошибкой

Recommended Posts

Здравствуйте уважаемые разработчики. К сожалению я не понял как зайти в раздел на форуме для тех кто купил скрипт, поэтому пишу здесь. Скрипт я купил давно уже, сегодня продлил. 

 

Суть моего вопроса такая. Есть один сайт на 10.0 версии, но мы его обновлять не хотим, слишком много там сделано чего. Но переход на новую версию php 7 был вынужден.

 

При переходе на php 7 замечена пока одна проблема, прошу помогите ее устранить. При загрузке картинок в новость происходит ошибка "Загрузка файла: file_name.jpg завершилась ошибкой. Причем сам файл загружен, в этом можно убедиться при обновлении страницы, тогда он показывается уже загруженным.

 

Очень нужно решение. Заранее благодарю.

 

 

Share this post


Link to post
Share on other sites

 

Причин проблемы может быть несколько:

 

1. Возможно нет прав на запись в папку uploads/ и все вложенные в нее папки и подпапки. Решение: установить на все папки и подпапки CHMOD 777

 

2. Если картинка очень большая, возможно не хватает оперативной памяти выделенной для PHP в настройках скрипта. Решение: проверить на маленьких картинок, если проблем нет, то обратитесь в службу поддержки вашего хостинга для увеличения лимитов памяти в настройках PHP интерпретатора.

 

3. Неправильно настроен PHP интерпретатор, для него в его настройках не указаны настройки для временных файлов. Решение: обратиться в службу вашего хостинга, чтобы проверили правильность и корректность настроек PHP интерпретатора в области настроек хранения временных файлов. 

Share this post


Link to post
Share on other sites

Возможно у вас такая проблема, как у меня. Появилась она после подключения FastCGI.

 

Если у вас CentOS, то по пути - /etc/httpd/conf.d/fcgid.conf
Добавить в fcgid.conf строку FcgidMaxRequestLen 2097152

Это увеличение загружаемых файла на 2МБ, можете больше добавить.
Еще на всякий можете вот это пихнуть FcgidMaxRequestInMem 6555536.

И главное, перезагружаем сервер. Командой  - service httpd restart
Либо еще каким-нибудь образом.

Если не поможет или такого файла нет, то может он тут лежит /etc/apache2/mods-enabled/fcgid.conf 

Share this post


Link to post
Share on other sites

Еще один вариант - https/http. У меня прописано было https, но в админку обращался http, чего незаметил. И срабатывала кросс-сайтовая блокировка.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.