CMS DataLife Engine - Система управления сайтами

Авторизация  
Classter00

Как обновить с v10 (win_1251) до v13 (utf8)?

Рекомендуемые сообщения

Здравствуйте. Хотел бы обновить один из сайтов с версии 10 (win 1251) до 13, но проблема состоит в том, что с версии 13 нет кодировки win 1251, только utf8 (как я понял). Так вот подскажите пожалуйста, каким образом можно обновиться, сохранив ресурс полностью в первозданном виде.

Предполагаю, единственное решение такое:

1) Сделать бекап БД и перекодировать в utf8 вместе с шаблонами.
2) Скачать dle 10 в utf8 и установить.
3) Восстановить БД на движке.
4) Залить v13 поверх 10 и запустить обновление через /upgrade.
5) Надеяться, что двиг примет старую структуру, так как если восстанавливать БД от старой на новой версии, то выдает ошибку о устарелости.

Спасибо за любые советы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
11 минут назад, Classter00 сказал:

Предполагаю, единственное решение такое:

Это неправильное решение

 

Цитата

Внимание !!!

На данном форуме существуют достаточно жесткие правила, поэтому прежде чем создавать свою тему убедитесь, что вы внимательно их прочитали и поняли.

 

1. Если ваша тема начинается с вопроса и вам нужна какая либо помощь, то в самой теме в обязательном порядке вы должны указывать ссылку на ваш сайт. Если ваш сайт находится в локальной сети и вы не можете предоставить ссылку, или вы не хотите публиковать открытой ссылки на ваш сайт, то отправляйте персональное сообщение с вопросом в службу поддержки непосредственно с сайта http://dle-news.ru/, вам ответят на ваш вопрос в персональном порядке, в случае если пользуетесь платной версией скрипта и обладаете лицензией на скрипт. Если вы пользуетесь демоверсией, то вам необходимо разместить сайт в сети интернет, и только потом обращаться за помощью. По находящимся на локальных компьютерах демоверсиям никакой помощи и поддержки на форуме не оказывается. Если вы не указали сайт, то ваша тема будет закрыта, а аккаунт на форуме заблокирован.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 часа назад, Classter00 сказал:

Предполагаю, единственное решение такое:

 

3 часа назад, Classter00 сказал:

4) Залить v13 поверх 10 и запустить обновление через /upgrade.

 

  • Спасибо 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 часов назад, alex32 сказал:

Внимание !!!

На данном форуме существуют достаточно жесткие правила, поэтому прежде чем создавать свою тему убедитесь, что вы внимательно их прочитали и поняли.

 

1. Если ваша тема начинается с вопроса и вам нужна какая либо помощь, то в самой теме в обязательном порядке вы должны указывать ссылку на ваш сайт. Если ваш сайт находится в локальной сети и вы не можете предоставить ссылку, или вы не хотите публиковать открытой ссылки на ваш сайт, то отправляйте персональное сообщение с вопросом в службу поддержки непосредственно с сайта http://dle-news.ru/, вам ответят на ваш вопрос в персональном порядке, в случае если пользуетесь платной версией скрипта и обладаете лицензией на скрипт. Если вы пользуетесь демоверсией, то вам необходимо разместить сайт в сети интернет, и только потом обращаться за помощью. По находящимся на локальных компьютерах демоверсиям никакой помощи и поддержки на форуме не оказывается. Если вы не указали сайт, то ваша тема будет закрыта, а аккаунт на форуме заблокирован.

У меня три купленных лицензии, но писать в ТП могут только с расширенной, разве нет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
11 минут назад, Classter00 сказал:

У меня три купленных лицензии, но писать в ТП могут только с расширенной, разве нет?

У меня 10 лицензий, а правила форума одинаковы для всех.

Цитата

. Если ваша тема начинается с вопроса и вам нужна какая либо помощь, то в самой теме в обязательном порядке вы должны указывать ссылку на ваш сайт....

...Если вы не указали сайт, то ваша тема будет закрыта, а аккаунт на форуме заблокирован.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, Classter00 сказал:

Предполагаю, единственное решение такое:

Неверное априори решение. Которое даже близко делать не нужно.

30 минут назад, Classter00 сказал:

но писать в ТП могут только с расширенной, разве нет?

Речь идет о создании темы и вопроса здесь на форуме. Правила даны относительно форума. А создавать темы вы можете независимо от того есть расширенная лицензия или нет, главное соблюдение правил форума.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация