CMS DataLife Engine - Система управления сайтами

Авторизация  
saizar

Ошибка при установке dle 11.2 (PHP extension Crypt)

Рекомендуемые сообщения

Здравствуйте! Адрес сайта playgrad.ru

 

При установке новой версии движка возникает следующая ошибка

 

PHP extension Crypt must be loaded for password_hash to function

 

В интернете удалось найти что возможно не хватает mycrypt , пробовал поставить mycrypt, на втором шаге ошибка php5enmod: command not found

 

Параметры моего сервера: 

 

Операционная система: Linux 2.6.32-042stab120.6
Версия PHP: 5.3.2-1ubuntu4.19
Версия MySQL: 5.1.66-0ubuntu0.10.04.3 MySQLi
Информация о GD: GD Version: 2.0, FreeType Support: Enabled, FreeType Linkage: with freetype, T1Lib Support: Enabled, GIF Read Support: Enabled, GIF Create Support: Enabled, JPEG Support: Enabled, PNG Support: Enabled, WBMP Support: Enabled, XPM Support: Disabled, XBM Support: Disabled, JIS-mapped Japanese Font Support: Disabled,
Module mod_rewrite Включен
   

Выделено оперативной памяти:

512M
Отключенные функции: exec, passthru, shell_exec, system, proc_open, popen
Изменено пользователем saizar

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как совет, рекомендую обновлять PHP сразу на линейки не ниже 5.5.x, чтобы функции шифрования сразу были доступны в нативных вариантах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

обновление php не помогает.при установки влазит ошибка (PHP extension Crypt must be loaded for password_hash to function)если установился то не работает ни одна тема.Как что это может быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
48 минут назад, svm22 сказал:

обновление php не помогает.при установки влазит ошибка (PHP extension Crypt must be loaded for password_hash to function)если установился то не работает ни одна тема.Как что это может быть?

Все помогает. Вы либо не обновили PHP до минимально необходимой версии PHP. А это PHP 5.4 для актуальной версии. Либо если у вас PHP ниже 5.5, то для линейки 5.4.x не установлено расширение  PHP Crypt

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
29 минут назад, celsoft сказал:

Все помогает. Вы либо не обновили PHP до минимально необходимой версии PHP. А это PHP 5.4 для актуальной версии. Либо если у вас PHP ниже 5.5, то для линейки 5.4.x не установлено расширение  PHP Crypt dle12.1 версия php7.1 

dleобновление php не помогает.при установки влазит ошибка (PHP extension Crypt must be loaded for password_hash to function)если установился то не работает ни одна тема.Как что это может быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 минуты назад, svm22 сказал:

Как что это может быть?

Версия php на сервере какая?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, svm22 сказал:

php 7.1

 

Тогда пишите с клиентского аккаунта сюда https://dle-news.ru/index.php?do=feedback, описав проблему, предоставив адрес сайта, доступ к админке, и ftp

Изменено пользователем germanydletest

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Denwer_PHP-7.1.8_MYSQL-5.7_Optimazed

и какая форма связи если dle yt cnfyjdbnmczDenwer_PHP-7.1.8_MYSQL-5.7_Optimazed

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, svm22 сказал:

Denwer

цитата из правил

Цитата

По находящимся на локальных компьютерах демоверсиям никакой помощи и поддержки на форуме не оказывается. 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 минут назад, svm22 сказал:

php 7.1

Данного сообщения на PHP 7.1 быть не может, т.к. у данной версии встроенные функции password_hash http://php.net/manual/ru/function.password-hash.php

 

По факту у вас на сервере вероятно другая версия PHP.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

хорошо вы правы а тогда баран!!!!!!!!!!!!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, svm22 сказал:

хорошо вы правы а тогда баран!!!!!!!!!!!!!!

Сарказм? Если да, то зря. Я же вам привел ссылку на документацию PHP. Вам ведь выдает эту ошибку именно эта функция, ссылку на которую я вам привел. И в документации PHP четко написано, что в PHP7 она входит по умолчанию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Пару слов в копилку.

По поводу Локалки на Дэнвере. Уважаемый germanydletest любой, или многие, пробуют свой сайт на локалке, прогоняют его, а затем уже заливают на сервер.

По поводу локалок (под винду) Дэнвер лучший (с обновлённым РНР, Апачем и РНРМуАдмином). Перепробовал кучу.

И так по теме.

Сайт rugby.az (лицензия)

Планирую обновиться до последней версии, но естественно, прежде хочу прогнать на локалке.

И так. РНР7 - установленная на Дэнвере (см. прикреплённый файл)

При попытке установить ДЛЕ13 (и 12.1) выходит не "привычное" окно. Такое впечатление, что не подключаются стили.

С другими скриптами подобное не происходит. Выкладываю скрины, что бы не быть многословным. 

 

1. Версия РНР

image.jpg

 

2. Установщик ДЛЕ

3.jpg

3. Установщик ВордПресс
1.jpg

 

4. Установщик phpFox

2.jpg

Изменено пользователем hawkeye

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, hawkeye сказал:

По поводу локалок (под винду) Дэнвер лучший (с обновлённым РНР, Апачем и РНРМуАдмином). Перепробовал кучу.

Субъективное мнение каждого.

2 часа назад, hawkeye сказал:

И так. РНР7 - установленная на Дэнвере (см. прикреплённый файл)

При попытке установить ДЛЕ13 (и 12.1) выходит не "привычное" окно. Такое впечатление, что не подключаются стили.

Open-server (ospanel) v.5.2.7 (не последняя версия разработчика), php 7.1 для данных версий dle ничего подобного не наблюдается!

  • Поддерживаю 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 часа назад, hawkeye сказал:

По поводу локалок (под винду) Дэнвер лучший (с обновлённым РНР, Апачем и РНРМуАдмином).

Спасибо, поржал ))))))))))

Пару слов в копилку: руки из попы выдернуть, перевернуть, вставить в нужное место. 

  • Нравится 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, alex32 сказал:

Спасибо, поржал ))))))))))

Пару слов в копилку: руки из попы выдернуть, перевернуть, вставить в нужное место. 

может всё-таки соблюдать правила приличия? Иначе, в инете все герои...

Ржать можете сколько хотите. Ваше право, а вот оскорблять никто не давал права!

Админу! Или вы научите и принудите юзеров придерживаться ВАШИХ ЖЕ ПРАВИЛ, или же потеряете клиентов... 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

9 часов назад, hawkeye сказал:

Админу! Или вы научите и принудите юзеров придерживаться ВАШИХ ЖЕ ПРАВИЛ, или же потеряете клиентов...

Админу! Тут прямое оскорбление разработчика!

 

В 08.05.2018 в 20:57, svm22 сказал:

хорошо вы правы а тогда баран!!!!!!!!!!!!!!

:D

мальчик, ты сначала немного выше денвера вырасти, а потом тут какахами кидайся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
17 часов назад, hawkeye сказал:

2. Установщик ДЛЕ

Откройте консоль браузера, там будет показано, что не так, и почему не загрузились стили. По этим ошибкам будет понятно в чем именно проблема.

 

 

P.S. alex32, это совсем другой пользователь писал, не тот с кем была переписка. Просто поднятая старая тема. Поэтому призываю всех внимательно смотреть кто что пишет, и когда вообще писал.

 

P.P.S. Также предупреждаю всех без исключения, о недопустимости оскорблений друг друга.

  • Поддерживаю 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 06.07.2018 в 14:51, proba сказал:

Субъективное мнение каждого.

Open-server (ospanel) v.5.2.7 (не последняя версия разработчика), php 7.1 для данных версий dle ничего подобного не наблюдается!

Спасибо! Я пробовал эту прогу, правдо давно. И тогда Дэнвер справлялся со своей задачей, и, видимо из-за большого веса Open-server, выбор пал на Дэнвер.

Вчера установил последнюю версию, размер огромен, но задачу свою исправно выполняет. 

Ещё раз спасибо!

Изменено пользователем hawkeye

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 06.07.2018 в 21:08, hawkeye сказал:

Пару слов в копилку.

По поводу Локалки на Дэнвере. Уважаемый germanydletest любой, или многие, пробуют свой сайт на локалке, прогоняют его, а затем уже заливают на сервер.

По поводу локалок (под винду) Дэнвер лучший (с обновлённым РНР, Апачем и РНРМуАдмином). Перепробовал кучу.

Использование локальной демоверсии ДЛЕ допускается, если Вы не запрашиваете помощи на данном форуме. Запросили помощи, будьте любезны либо в платную поддержку (если не хотите сайт светить), либо указываете ресурс, чтобы пользователи могли убедиться в наличии проблемы и способах ее решения. Телепатов на форуме нет :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация