CMS DataLife Engine - Система управления сайтами

Авторизация  
D_Moon

Не отображается ютуб видео

Рекомендуемые сообщения

Здравствуйте,

сайт wrc-info.ru

версия 10.0
переехал на новый хостинг рег.ру, прикрутил ssl сертификат.

Все вроде бы хорошо работает, но теперь не отображается видео с ютуба. (вставляю кнопкой tube, [media=http://]. Вроде бы проблема возникла как только ssl подключил. Подскажите пожалуйста, В чем может быть проблема, что я не так сделал?

 

для примера, видео есть здесь https://wrc-info.ru/main/news/16215-den-molodezhi-v-finlyandii.html. В коде даже вроде висит, но не отображается.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
54 минуты назад, D_Moon сказал:

Здравствуйте,

сайт wrc-info.ru

версия 10.0
переехал на новый хостинг рег.ру, прикрутил ssl сертификат.

Все вроде бы хорошо работает, но теперь не отображается видео с ютуба. (вставляю кнопкой tube, [media=http://]. Вроде бы проблема возникла как только ssl подключил. Подскажите пожалуйста, В чем может быть проблема, что я не так сделал?

 

для примера, видео есть здесь https://wrc-info.ru/main/news/16215-den-molodezhi-v-finlyandii.html. В коде даже вроде висит, но не отображается.

возможно проблема с самим ютубом, так как у меня тоже он не парсится через теги, но я вышел из проблемы с доп полями и в коде шаблона вставил

<iframe class="embed-responsive-item" width="560" height="315" title={title} src="[xfvalue_treyler]" frameborder="0" allowfullscreen></iframe>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

но до установки ssl все работало. В чистом движке тоже такая проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нашел такое решение на одном сайте.

Цитата

Устаревшая версия движка, в которой данные ссылки еще не поменяны и все ролики с Youtube по умолчанию превращаются в старый протокол, а далее статья отправляется в базу данных и там хранятся в неизменном виде.
Заходим engine/classes/parse.class.php и делаем массовую замену (Ctrl+H) через любой более-менее серьезный редактор следующие направлениям. 

http:// —> https://
http://www. —> https://www.


Заливаем файл назад и идем в адмиинку в раздел перестроения публикаций. /admin.php?mod=rebuild


Запускаем процесс перестроения, который пересохранит все опубликованные новости на сайте. А так как мы внесли правки в правила сохранения, то все протоколы перезапишутся на https

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 часов назад, D_Moon сказал:

нашел такое решение на одном сайте.

 

не знаю, у меня ни на http: ни на https: медиа тег не работал, в новости вобще выдавало просто ссылку и все

у меня при ssl-сертификате браузер выдавал ошибку безопастности и все, а так у тебя не загружается сам iframe

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
44 минуты назад, alukardua сказал:

не знаю, у меня ни на http: ни на https: медиа тег не работал, в новости вобще выдавало просто ссылку и все

Это потому что на вашем сервере отключены внешние исходящие соединения, т.к. код для этих ссылок дают сами сервисы и DLE их не может получить. Вам нужно в тех. поддержку хостинга обратиться, для снятия этих ограничений на сервере.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, celsoft сказал:

Это потому что на вашем сервере отключены внешние исходящие соединения, т.к. код для этих ссылок дают сами сервисы и DLE их не может получить. Вам нужно в тех. поддержку хостинга обратиться, для снятия этих ограничений на сервере.

ну мне не критично, я использую доп поле и этот код в шаблоне <iframe class="embed-responsive-item" width="560" height="315" title={title} src="[xfvalue_treyler]" frameborder="0" allowfullscreen></iframe>

разобрался, если ссылка https://www.youtube.com/watch?v=0DlYS89g6LA то все отображается, а если https://www.youtube.com/embed/0DlYS89g6LA то не парсит

Изменено пользователем alukardua

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, alukardua сказал:

разобрался, если ссылка https://www.youtube.com/watch?v=0DlYS89g6LA то все отображается, а если https://www.youtube.com/embed/0DlYS89g6LA то не парсит

В этом теге вставляется ссылка из URL браузера!!!, а не ссылка, которая стоит в поделится или где то еще. Это очень важно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, celsoft сказал:

В этом теге вставляется ссылка из URL браузера!!!, а не ссылка, которая стоит в поделится или где то еще. Это очень важно.

уже понял, но мне проще с доп полями, так как использую модуль трейлеров

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
9 часов назад, alukardua сказал:

уже понял, но мне проще с доп полями, так как использую модуль трейлеров

Проще вам, а не D_Moon, "холивар" не разводите в каждой чужой теме. Отвечать не нужно на мой пост.;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 часов назад, Captain сказал:

"холивар" не разводите в каждой чужой теме. Отвечать не нужно на мой пост.;)

Это и к вам относиться.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 05.09.2018 в 11:46, Gameer сказал:

Это и к вам относиться.

Да ему промокод же нужно проспамить, а то реф. отчисления падают, кризис и все дела.
А по теме, если уж и использовать доп. поле, то чисто под ID ролика, но никак не под всю ссылку.

  • Нравится 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, Qusserel сказал:

Может это из-за блокираторов рекламы?

Вряд ли, у самого adblock стоит и все нормально идет

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 04.09.2018 в 14:39, celsoft сказал:

Это потому что на вашем сервере отключены внешние исходящие соединения, т.к. код для этих ссылок дают сами сервисы и DLE их не может получить. Вам нужно в тех. поддержку хостинга обратиться, для снятия этих ограничений на сервере.

100% напишите хостерам, пускай снимут ограничения..

у меня такой же прикол был.

В 05.09.2018 в 01:39, Captain сказал:

Проще вам, а не D_Moon, "холивар" не разводите в каждой чужой теме. Отвечать не нужно на мой пост.;)

)) а ему срочно нужно было найти решение

вот только я не понял, нашел он его или нет.. четко ведь написали где копать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А через антишпионов может такое быть? Я просто недавно поставил себе AdwCleaner https://www.besplatnyeprogrammy.ru/security/antispy Нашел вот здесь. Так тоже были некоторые проблемы с ютубом. И как быть не знаю. С одной стороны антишпион нужен, а с другой стороны ютуб тупит по страшному((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 03.09.2018 в 23:32, D_Moon сказал:

[media=http://]. Вроде бы проблема возникла как только ssl подключил. Подскажите пожалуйста, В чем может быть проблема, что я не так сделал?

Защищенный протокол не показывает незащищенный контент.

Заменить http:// на https://

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация